EMEA Degraded Performance

Incident Report for GoMomentus

Resolved

The performance issue affecting users in the EMEA region has been resolved.
All services are functioning as expected, and users should no longer experience degraded performance.
We will continue to closely monitor the system to ensure stability and confirm that no further impact occurs.
Thank you for your patience and cooperation throughout this incident.
Posted Jan 20, 2026 - 09:45 UTC

Monitoring

A fix has been implemented, and system performance in the EMEA region is now improving.
We are currently monitoring the situation to ensure stability and confirm that the issue has been fully resolved.
We will provide a final update once we verify that all services are operating normally.
Thank you for your patience throughout this incident.
Posted Jan 20, 2026 - 07:11 UTC

Update

We have identified the root cause of the performance issues impacting users in the EMEA region.
Our team is continuing to work on a permanent fix to fully restore normal service levels.
At this stage, remediation efforts are still in progress, we will share another update as soon as we move into the next stage of the process.
Thank you for your patience and understanding while we work to resolve the issue.
Posted Jan 19, 2026 - 17:44 UTC

Identified

We have identified the underlying cause of the performance issues affecting users in the EMEA region.
Our team is now working on implementing a fix to restore normal service levels.
Further updates will be shared as we make progress.
Thank you for your continued patience.
Posted Jan 19, 2026 - 15:49 UTC

Update

Our team is still actively investigating the performance issue affecting users in the EMEA region.
We are working to identify the root cause and will provide additional updates as soon as new information becomes available.
Thank you for your continued patience.
Posted Jan 19, 2026 - 14:38 UTC

Update

We are continuing to investigate this issue.
Posted Jan 19, 2026 - 14:04 UTC

Investigating

We are currently experiencing degraded performance across the system affecting users in the EMEA region.
Our team is actively investigating the issue and working to restore normal performance as quickly as possible.
Further updates will be provided as soon as they become available.
Thank you for your patience and understanding.
Posted Jan 19, 2026 - 14:03 UTC
This incident affected: Momentus Enterprise.