Data Processing Delays - Reporting Tools Affected

Incident Report for GoMomentus

Resolved

The issue affecting users in the EMEA region has now been fully resolved.
System functionality has returned to normal, and all services are operating as expected.
Thank you for your patience and understanding
Posted Jan 19, 2026 - 12:30 UTC

Monitoring

A fix has been implemented for the issue affecting users in the EMEA region, and we are currently monitoring system performance to ensure full stability.
We will provide another update once we confirm that the issue is fully resolved.
Thank you for your continued patience.
Posted Jan 19, 2026 - 12:07 UTC

Identified

We have identified the root cause of the system errors currently impacting users in the EMEA region.
Our team is now working on a fix to restore full service functionality.
We will share further updates as progress continues.
Thank you for your patience.
Posted Jan 19, 2026 - 12:01 UTC

Investigating

We are currently experiencing Errors across the system . Our team is actively investigating the issue.
We will provide you with further updates as soon as they are available.
Only EMEA region is affected

Thank you for your patience and understanding.
Posted Jan 19, 2026 - 11:51 UTC
This incident affected: Momentus Enterprise.