US Elite service disruption 4/23/25 - Morning

Incident Report for GoMomentus

Resolved

All services have been restored and are now operating normally. Our team will continue to closely monitor the system to ensure continued stability. Please reach out to support if you are still experiencing issues.

Thank you for your patience and support.
Posted Apr 23, 2025 - 13:16 UTC

Monitoring

We have identified and resolved the issue that caused the recent service outage. All services have been restored and are now operating normally. Our team will continue to closely monitor the system to ensure continued stability. Please reach out to support if you are still experiencing issues.

Thank you for your patience and support.
Posted Apr 23, 2025 - 12:28 UTC

Investigating

We are currently experiencing a service outage, and our team is actively investigating the issue. We are working to resolve it as quickly as possible and will provide updates as soon as we have more information.

Thank you for your patience and understanding.
Posted Apr 23, 2025 - 12:15 UTC
This incident affected: Momentus Elite.