Elite - EMEA Outage

Incident Report for GoMomentus

Resolved

The EMEA outage has been successfully resolved.
All services are now back online and operating normally.
Thank you for your understanding.
Posted Jan 09, 2026 - 10:45 UTC

Identified

We have identified the issue and our Teams are actively working to resolve it
We will provide further updates when available.
Posted Jan 09, 2026 - 10:36 UTC

Investigating

We are currently experiencing an outage impacting EMEA regions only. Our teams are actively investigating and working toward resolution. Further updates will be shared as available.
Posted Jan 09, 2026 - 10:30 UTC
This incident affected: Momentus Elite.