Enterprise Performance issues

Incident Report for GoMomentus

Resolved

Rollback of recent monitoring update has completed - all regions should be experiencing significantly improved performance.
Posted Aug 25, 2026 - 14:13 UTC

Monitoring

We have now completed the rollback of a recent monitoring update in both the North America and Asia Pacific regions. Customers in these regions should notice significantly improved performance. We are continuing to monitor performance to confirm resolution as we work to address in each region.

The EMEA region rollback is scheduled to complete after hours this evening. We will provide a final update once this is complete.

We're sorry for any disruption this may have caused and thank you for bearing with us.
Posted Aug 24, 2026 - 20:04 UTC

Identified

We have completed the rollback of a recent monitoring update in the North America region. Customers in this region should now notice significantly improved performance.

We are continuing this rollback process for the Asia Pacific region and will provide updates as it progresses.

We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Aug 24, 2026 - 17:39 UTC

Investigating

We are currently investigating an issue related to a recent upgrade to our monitoring system. This update was planned and tested in our lower environments prior to release; however, once deployed at production scale, it resulted in a higher-than-expected demand on system resources, which may be causing degraded performance for some customers.

To mitigate impact, we have begun rolling back this change to restore the system to its previous stable state. We have also opened a critical priority ticket with our monitoring vendor to investigate the underlying cause and prevent recurrence.

We will continue to provide updates as the rollback progresses and as we learn more from our vendor's investigation. We apologize for any disruption this may have caused and appreciate your patience while we work to resolve this.
Posted Aug 24, 2026 - 14:54 UTC
This incident affected: Momentus Enterprise.