North America Outage 3/4/26 - Afternoon

Incident Report for GoMomentus

Resolved

An unexpected restart of a primary database server in the North America region caused a temporary service disruption. During this time, some users encountered a blank page when attempting to sign in to Momentus Elite.

Service has now been stabilized, and we are continuing to monitor performance to ensure reliability. If you're still experiencing issues getting signed in, please reach out to Support at elitesupport@gomomentus.com.
Posted Mar 04, 2026 - 20:27 UTC

Monitoring

We have identified the cause of the issue impacting access to Momentus Elite in our North America region. Some customers may have experienced a blank page when attempting to sign in.

Our team has implemented a fix and is actively monitoring the system to ensure stability. No action is required at this time. We will provide additional updates if necessary.
Posted Mar 04, 2026 - 20:18 UTC

Investigating

We’re investigating reports of some users not being able to access Momentus Elite in our North America region. Some customers may experience a blank page when trying to sign in. Our team is actively investigating the cause. No action required at this time. We will provide an update as soon as possible.
Posted Mar 04, 2026 - 20:09 UTC
This incident affected: Momentus Elite.