AP Elite is down

Incident Report for GoMomentus

Resolved

The service disruption affecting APAC has been fully resolved. All systems are now operating normally.
We will continue monitoring to ensure stability. Thank you for your patience. Please report any continued issues to our Support team using elitesupport.ap@gomomentus.com using #helpnow
Posted Dec 05, 2025 - 12:14 UTC

Investigating

Please be advised that the Momentus Elite AP instance is currently down.
Impact: Only AP region is affected.
EMEA and US regions are operating normally.
Our team is investigating and will provide updates as soon as possible.
Posted Dec 05, 2025 - 11:46 UTC
This incident affected: Momentus Elite.