SendGrid engineers have monitored the issue and confirmed the issue with email deliveries to Microsoft has recovered to normal levels. All services are now operating normally at this time.
Posted Sep 04, 2026 - 21:08 UTC
Monitoring
We continue to monitor an ongoing issue with our email delivery provider, SendGrid, that is affecting emails being delivered to Microsoft-hosted email services.
Based on updates from the provider, we are seeing a recovery in our services for customer sending to Microsoft and MS 365 supported recipients, and we'll continue to monitor.
We are closely monitoring updates from SendGrid and will provide additional information as it becomes available.
Posted Sep 04, 2026 - 15:17 UTC
Update
We are continuing to monitor the ongoing SendGrid service issue that is impacting customers globally. Our teams remain engaged and are closely tracking the situation. We will provide further updates as soon as additional information becomes available. Thank you for your patience and understanding.
Posted Sep 04, 2026 - 12:22 UTC
Update
We are continuing to investigate this issue.
Posted Sep 04, 2026 - 09:14 UTC
Investigating
We are currently experiencing a widespread issue with SendGrid that began around midnight. This is affecting customers globally and may impact email delivery and related services. Our teams are actively monitoring the situation and working with the provider to restore full functionality as quickly as possible. We will continue to provide updates as more information becomes available. We apologize for the inconvenience and appreciate your patience while we work toward a resolution.