EMEA Elite is down

Incident Report for GoMomentus

Resolved

The issue affecting access to the ELITE EMEA instance has been resolved.
All systems are functioning normally.
Thank you for your patience and understanding.
Posted Mar 25, 2026 - 10:36 UTC

Identified

Access to the ELITE EMEA instance has been successfully restored.
Our teams continue to investigate the underlying issue.
Thank you for your patience.
Posted Mar 25, 2026 - 10:20 UTC

Investigating

We are currently experiencing an issue impacting access to ELITE EMEA instance.
Our technical teams are actively investigating the issue.
Further updates will be shared as soon as more information is available.
Posted Mar 25, 2026 - 10:10 UTC
This incident affected: Momentus Elite.