Microsoft Incident affecting US WeTrack user sites

Incident Report for GoMomentus

Resolved

Our team has been monitoring an issue related to a Microsoft Azure (Entra) incident that caused intermittent service disruptions for some US customers. Microsoft has taken steps to mitigate the issue, and service has stabilized. We will continue to monitor closely, but at this time the incident is considered resolved.

We appreciate your patience while this was being addressed. Please contact Support if you continue to experience any issues or have questions.
Posted Apr 27, 2026 - 12:18 UTC

Identified

Our team has been made aware of an issue caused by an ongoing Microsoft Azure (Entra) incident that is causing a disruption in service to our US customers. Some users may experience periods of brief service interruption while Microsoft investigates and resolves the issue on their side. Momentus is continueing to monitoring the situation and will keep our status page updated as progress is made this afternoon. Please contact Support if you have any questions.

Microsoft's status page may be found here: https://azure.status.microsoft/en-us/status
Posted Apr 24, 2026 - 18:01 UTC
This incident affected: Momentus WeTrack.