Elite US - Service Availability Update

Incident Report for GoMomentus

Resolved

All services are operating as expected.
Monitoring will continue to ensure ongoing stability.
Thank you for your patience.
Posted Jan 28, 2026 - 12:20 UTC

Monitoring

Maintenance activities have been completed, and the system has been restored.
Our teams are currently monitoring to ensure full stability and performance.
Thank you for your patience.
Posted Jan 28, 2026 - 12:14 UTC

Identified

The scheduled maintenance window has extended longer than anticipated, and the team is actively working to restore full functionality.
We will share additional updates as progress continues.
Thank you for your patience and understanding.
Posted Jan 28, 2026 - 11:29 UTC
This incident affected: Momentus Elite.