US Elite Outage - 1-26-26 Morning

Incident Report for GoMomentus

Resolved

The issue with logging into Momentus Elite has been fully resolved. We apologize for any disruptions this caused.
Posted Jan 26, 2026 - 15:21 UTC

Monitoring

We are monitoring all accounts to make sure all come back online. We will update again once all clients have access to their accounts.
Posted Jan 26, 2026 - 15:08 UTC

Identified

The issue causing login problems has been identified, and databases should be coming back online. This can take a little more time before all clients can successfully log in.
Posted Jan 26, 2026 - 15:06 UTC

Investigating

We’re investigating reports of login issues from users in the US region. Some customers may experience a blank login screen when trying to access Momentus Elite. Our team is actively investigating the cause. No action required at this time. We will update again as we learn more.
Posted Jan 26, 2026 - 15:00 UTC
This incident affected: Momentus Elite.